Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 03, 2026 - 08:00 UTC
Scheduled
We would like to inform you about upcoming SEPA system availability in relation to the Easter holiday periods.
Due to the Catholic Easter holidays, April 3rd (Good Friday) and April 6th (Easter Monday) will be non-working days for the SEPA system. As a result, no EUR payments will be processed on these dates. Payment orders submitted with an execution date of April 2nd, 2026, or April 7th, 2026, will be processed as usual.
Please also note that during the Orthodox Easter holidays in Bulgaria, April 10th (Good Friday) and April 13th (Easter Monday) will remain working days for the SEPA system. EUR payment orders will therefore be processed as usual on these dates.
Please do not hesitate to contact us at https://support.weavr.io with any questions or concerns you might have.
Posted Mar 31, 2026 - 10:06 UTC
This scheduled maintenance affects: Production environment, Incoming Wire Transfers, Outgoing Wire Transfers, and Sends & Transfers.