Card Holder Update Requests Failing

Incident Report for Weavr Status Page

Resolved

This incident has now been resolved.

If you have any questions or would like to discuss it further, please don’t hesitate to get in touch.
Posted Oct 28, 2025 - 16:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2025 - 14:19 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 28, 2025 - 12:23 UTC

Update

We are continuing to investigate this issue.
Posted Oct 28, 2025 - 10:33 UTC

Investigating

We are currently investigating an issue affecting cardholder update requests (e.g., updates to cardholder name, delivery address and upgrading cards to physical and similar details). Virtual card creation and other card operations remain unaffected.

We have raised a critical ticket with our card processor and our team is actively working with their team to restore full functionality as quickly as possible.
Posted Oct 28, 2025 - 09:56 UTC
This incident affected: Plastic Card Production.