Card Fulfilment Tracking Delays

Incident Report for Weavr Status Page

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 08:48 UTC

Investigating

We are currently experiencing delays in receiving tracking information from our card production partner. As a result, physical card orders placed since 20th May 2025 may not yet appear as "in transit" and tracking codes may be unavailable.

Our team is actively working to resolve the issue. We will provide updates as soon as tracking data is restored and card statuses are updated.

We apologise for the inconvenience and appreciate your patience.
Posted May 30, 2025 - 13:42 UTC
This incident affected: Plastic Card Production.