Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 01, 2025 - 17:06 UTC
Scheduled
Please be advised that our office will operate with reduced hours and staffing during the upcoming holiday period. Critical support will remain available for emergencies throughout this time.
Public Holiday Hours:
- 24th December (PM) - Reduced staffing - 25th December – Closed (Public Holiday) – On-call support available for P1 issues - 26th December – Reduced staffing - Monday 29th December - Reduced staffing - Tuesday 30th December - Reduced staffing - Wednesday 31st December - Reduced staffing - 1st January – Closed (Public Holiday) – On-call support available for P1 issues
Card Production:
- Card production will close from midday on Tuesday 24th December, and will reopen on Tuesday 2nd January 2025. We will continue to import and process data on December 24th, 29th and January 3rd. - Dispatch processing will begin as quickly as possible from January 2nd 2026.
Banking:
- SEPA deposits and transfers will not be processed on the following dates: - 25th December 2025 - 26th December 2025 - 1st January 2026
* Normal processing will resume the next business day.
Additional Information:
In the event of an emergency or critical situation during the holiday period, please report it via our support portal at https://support.weavr.io
Thank you for your understanding. If you have any questions or need further assistance, don’t hesitate to reach out.
Posted Dec 01, 2025 - 17:05 UTC
This scheduled maintenance affects: Plastic Card Production, Sends & Transfers, and Support Team.