Visa Network Incident Impacting Card Payments

Incident Report for Weavr Status Page

Resolved

This issue has now been fully resolved.

Visa is currently conducting an internal review of the incident to help prevent similar occurrences in the future.

If you have any questions or would like to discuss this further, please do not hesitate to contact us through your usual channels.
Posted May 29, 2026 - 19:39 UTC

Update

The issue continues to be treated as a high priority and remains under active investigation.
Posted May 29, 2026 - 18:30 UTC

Monitoring

We are currently aware of an ongoing Visa network incident that may impact some card payment authorisations.

As a result, some cardholders may experience intermittent transaction declines or payment failures. Our team is actively monitoring the situation alongside our partners, and we will provide further updates as more information becomes available.

We apologise for any inconvenience caused.
Posted May 29, 2026 - 17:48 UTC
This incident affected: Card Authorisations.